Help with Vacuum pump

Moderators: bohica2xo, Tim, Dougflas, HECAT

psychedvike
Posts: 1
Joined: Sun Jun 11, 2017 3:57 pm

Help with Vacuum pump

Postby psychedvike » Sun Jun 11, 2017 4:23 pm

I just picked up a Watsco 4 cfm vacuum pump. From what was told it was brand new. It was purchased by an old guy some years ago and it set in his shop. He retired and has now pasted away. The pump is clean and looks like it has never been touched. There was no oil in it. So I took it home filled it with oil and started it up. It will pull a really strong vacuum for about two or three minutes, Then as it gets warm it will pull less vacuum then stop. it is getting too tight for the motor to turn it. I drained it and pulled the tank off. I pulled the side of the pump off. It was clean inside and all looked brand new. I couldn't open it any further because the impeller I think is pressed on and I didn't want to damage the pump buy trying to pull it off to see the other side of the pump. I put it back together and same thing. It stops as soon as it warms up. Any ideas as to why this is happening and how to fix it?
doogdoog
Posts: 1
Joined: Thu Jan 25, 2018 11:43 pm

Re: Help with Vacuum pump

Postby doogdoog » Thu Jan 25, 2018 11:59 pm

Aloha,
This may be way too late but I had a new JB vacuum pump that I used only one time about 13 yrs. maybe a little longer that had problems when I tried to use it in Jan 2018. I filled it with oil, plugged it in and the motor wouldn't turn. I tried it again and the motor began to spin but the pump was not turning, I flipped the pump over and saw that the plastic sleeve connecting the motor shaft to the pump shaft was shattered. I purchased a repair kit and when I turned the motor on, it would not spin. I removed the pump from the motor and opened up the pump and cleaned out the slot where the two rectangular vanes were and reinstalled it. I turned on the motor and it would go about 3/4 of a turn and then stop. There are screws that holds the pump together that you have to play with to get the proper clearance so the vanes won't get hung up with the sides. After fiddling around with it , I finally got it to turn freely without any binding on the sides. Too late but I hope it helps someone.

Mahalo,
doogdoog
FloydQ
Posts: 1
Joined: Mon Oct 01, 2018 2:06 am

Re: Help with Vacuum pump

Postby FloydQ » Mon Oct 08, 2018 4:33 am

Can you link to the repair kit you used, Doogdoog? I need one as well by the looks of it.

Return to “Off Topic Chat”