02 Sierra 2500 No cold air

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, Dougflas, HECAT

EvergreenNJ
Posts: 1
Joined: Fri Jul 19, 2019 9:58 am

02 Sierra 2500 No cold air

Postby EvergreenNJ » Fri Jul 19, 2019 10:11 am

Please bare with me as air conditioning is not a subect i know much about. I recently bought this truck so i dont have much prior knowledge on it. Since I bought it a few months ago the A/C never worked and now that summer is here im feeling the heat!

I bought A/C pro at auto zone thinking it would be a simple refill, until I did some more research. Upon putting the gauge on the low port, I got a zero for a pressure reading ( did not know this was an indication of a leak). So I recharged the system to about 35 psi on the gauge. It took barely any of the can to reach this reading which I found strange. The clutch began to engage and cycle rapidly on and off for a few seconds at a time until it eventually stopped. I never once got cold air coming out of the vents.
So as I said I did some more research. I found that the clutch does work by sticking a paperclip in the switch, so I ruled that out. I rented a gauge set. There was still 20 psi in the low side and very little in the high side( less than 50 psi). I also ran a vacuum on the system to see if it held, which it did, but over a period of 45 minutes with the valves closed it dropped slighty, while still holding the vacuum. Also rented a leak detector kit which utilizes dye to detect the leak but have not used it yet, planned to do so tonight.
Really need some help here because taking it to the mechanic is going to put some hurt on my pockets right now. Any help would be appreciated.
Rich

Return to “Automotive Air Conditioning Forum”