Toyota HiAce AC not coming on

Friendly format provided to inquire about automotive a/c systems.
Archived Forum

Moderators: bohica2xo, Tim, JohnHere, Dougflas, HECAT

Ryan92
Posts: 2
Joined: Sat Oct 03, 2020 10:30 pm

Toyota HiAce AC not coming on

Postby Ryan92 » Sat Oct 03, 2020 10:38 pm

I recently replaced my vans AC compressor then just charged the system with about 1.5 of those recharge cans. It worked great a few times then stopped after a few days. I thought I might have over filled it so released some freon but the compressor still wouldn't come on. I thought I better do it properly so pulled a vacuum on the system etc. No leaks. Started to recharge but the compressor still won't come on. Any idea what it might be? Could air have damaged something? How many different sensors are there? Thanks
User avatar
Cusser
Posts: 584
Joined: Sun Apr 24, 2016 6:29 am

Re: Toyota HiAce AC not coming on

Postby Cusser » Sun Oct 04, 2020 8:39 am

Ryan92 wrote:I recently replaced my vans AC compressor then just charged the system with about 1.5 of those recharge cans.


Did you add pure R134a or the junk mix of R134a containing sealer?

What is your static pressure read? If you don't know what that means, stay as far away from auto AC as you can.
Ryan92
Posts: 2
Joined: Sat Oct 03, 2020 10:30 pm

Re: Toyota HiAce AC not coming on

Postby Ryan92 » Sun Oct 04, 2020 11:55 am

Nope no sealer. The static pressure is 50 psi at 15 degrees celsius. I thought that would be enough to get the compressor to engage as it didn't take much the first time I did it.
User avatar
JohnHere
Posts: 264
Joined: Sun May 13, 2018 10:20 am
Location: South Carolina Upstate - USA

Re: Toyota HiAce AC not coming on

Postby JohnHere » Wed Oct 07, 2020 7:00 am

A temperature of 15C (59F) is rather low for attempting to work on an MVAC system. Look for an ambient temperature of 21C (70F) or higher, working indoors in a heated area, if necessary. That might be why the compressor isn't engaging.

Return to “Automotive Air Conditioning Forum”